Supported Android and iOS Devices

*Only iOS and Android Operating Systems are Compatible with the App.

iOS:

Our app requires that your device has the following:

  • GPS
  • Camera with auto-focus
  • iOS 9 or newer

iOS devices that work well with our app:

iPhone - 4S, 5, 5C, 5S, 6, 6 Plus, 6S, 6S Plus, 7, 7 Plus
iPad - 2 Cellular, 3 Cellular, 4 Cellular
iPad Air - 1 Cellular, 2 Cellular
iPad Mini- 1 Cellular, 2 Cellular, 3 Cellular, 4 Cellular

 

Android:

Our app requires that your device has the following:

  • GPS
  • Camera with auto-focus
  • Android 4.1 or newer

Android devices that work well with our app:

Huawei Nexus 6P

HTC One
HTC One A9
HTC One M9

LG G 3, 4, 5
LG G Stylo
LG Nexus 5
LG Nexus 5X
LG V10

Moto E (2nd generation)
Moto G (2nd generation)
Motorola Nexus 6
Moto X (2nd generation)

Samsung Galaxy S4, S5, S6, S7 
Samsung Note 3, 4, 5, 6

Tablets: 

LG G Pad F7.0

 

Was this article helpful?
0 out of 0 found this helpful
Follow
Have more questions? Submit a request

Comments

  • Avatar
    Dorcas Carter

    Thank you